<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":5,"applicationTime":332,"agent":""}</script>
<script type="text/javascript">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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81921705-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>OStateIllustrated.com  -  Xavier Ross on his official visit</title>
<meta content='OStateIllustrated.com  -  Xavier Ross on his official visit' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-2eada6c4ef76b32c1d573f4c7ad6fd2ed16b2c21706319015a98c50ca76b4e2e.css" />

<script src="https://cdn.rivals.com/production/assets/application-bd8e0400049933d7d82b6800a27663d3f82104735ca93ffa4c021e578eb2a73b.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="oaSpDvzgCIhIrJe6FDQjEen3Jc16yoMopaV6ajedGa4PPGxye9/auGGPXuj5vwBgmreAY4Y7kJmXyg5RfVk5zg==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://oklahomastate.rivals.com/news/xavier-ross-on-his-official-visit' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/iffhrucnckyficfrkhqd' property='og:image'>
<meta content='Three-star defensive tackle Xavier Ross took a trip to Stillwater this weekend, along with a large number of others' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-04-30 21:13:39 -0500' property='article:published_time'>
<meta content='2018-04-30 21:31:10 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "oklahomastate.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='oklahomastate contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .oklahomastate #programming > h1 {
      background-color: #dd5309 !important; } }
  .oklahomastate > header .notification-link .count-container {
    background-color: #dd5309 !important; }
  .oklahomastate > header .wrapper-container {
    background-color: #dd5309 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .oklahomastate > header .wrapper-container {
        border-bottom: 5px solid #000000 !important; } }
  .oklahomastate > header .invalid-email-banner {
    background-color: #dd5309;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .oklahomastate > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .oklahomastate > header .invalid-email-banner a:hover {
      color: #000000; }
  @media screen and (max-width: 767px) {
    .oklahomastate > header .mobile-header {
      background-color: #000000 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .oklahomastate > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .oklahomastate > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .oklahomastate > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .oklahomastate > header .nav-row > ul,
    .oklahomastate > header .third-nav {
      background-color: white !important; }
    .oklahomastate > header .dropdown-toggle > i.fa {
      color: #dd5309 !important; } }
  .oklahomastate > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #dd5309; }
  
  .site-primary-font-color {
    color: #dd5309; }
  
  .site-primary-background-color {
    background-color: #dd5309; }
  
  .site-secondary-font-color {
    color: #000000; }
  
  .site-secondary-background-color {
    background-color: #000000; }
  
  :root {
    --outbrain-primary-color: #dd5309;
    --outbrain-secondary-color: #000000; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Oklahoma State" class="school-header" href="//oklahomastate.rivals.com"><img src="https://res-3.cloudinary.com/rivals/image/upload/dkbrstclbhsqtkycq7in" alt="Dkbrstclbhsqtkycq7in" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//oklahomastate.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;oklahomastate&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//oklahomastate.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;oklahomastate&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733131,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Xavier Ross on his official visit"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='@okstaterivals' name='twitter:site'>
<meta content='Xavier Ross on his official visit' name='twitter:title'>
<meta content='Three-star defensive tackle Xavier Ross took a trip to Stillwater this weekend, along with a large number of others' name='twitter:description'>
<meta content='https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/iffhrucnckyficfrkhqd' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1919154,"title":"Make that 2 2020&#x0027;s in as many days","slug":"make-that-2-2020-s-in-as-many-days","kind":"premium","site_id":108,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-30T21:35:58.107-05:00","summary":"Just a day after Eli Russ became the 1st commitment for OSU&#x0027;s 2020 class, the class has already doubled in size","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/make-that-2-2020-s-in-as-many-days","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1918978,"title":"Rivals100 WR trims his list","slug":"rivals100-wr-trims-his-list","kind":"premium","site_id":108,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-30T12:31:24.015-05:00","summary":"Following a visit to Stillwater, OKC Millwood star receiver DeMariyon Houston narrowed his list to 12.","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/rivals100-wr-trims-his-list","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1918880,"title":"Dax Hill sets The Opening - Dallas afire","slug":"dax-hill-sets-the-opening-dallas-afire","kind":"premium","site_id":108,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-30T07:49:10.228-05:00","summary":"Top 2019 Oklahoma State target Dax Hill put up great numbers across the board at The Opening&#x0027;s event in Dallas ","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/dax-hill-sets-the-opening-dallas-afire","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1918827,"title":"Russ talks commitment","slug":"russ-talks-commitment","kind":"premium","site_id":108,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-29T22:11:39.277-05:00","summary":"Right before Oklahoma State&#x0027;s Spring Game got underway, the Cowboys landed their first commitment for the 2020 class","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/russ-talks-commitment","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1918819,"title":"Cowboys sweep Bedlam","slug":"cowboys-sweep-bedlam","kind":"free","site_id":108,"sport":"baseball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-29T20:50:33.044-05:00","summary":"Josh Holliday&#x0027;s surging Oklahoma State Cowboys swept Oklahoma in the Bedlam Series over the weekend","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/cowboys-sweep-bedlam","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1918763,"title":"Cowboys wrap-up spring football","slug":"cowboys-wrap-up-spring-football-1","kind":"premium","site_id":108,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-29T16:57:27.631-05:00","summary":"Oklahoma State football wrapped up their spring session on Saturday with their annual Spring Game. ","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/cowboys-wrap-up-spring-football-1","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1918725,"title":"In Action: Spring Game","slug":"in-action-spring-game-3","kind":"premium","site_id":108,"sport":"football","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-04-29T14:09:33.388-05:00","summary":"Check out our gallery from OSU&#x0027;s Spring Game on Saturday.","deleted":false,"author_name":"Jeremy Cook","author_title":"OSI Photographer","permalink":"https://n.rivals.com/galleries/1702","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1917772,"title":"Cowboys enter final prep for Spring Game","slug":"cowboys-enter-final-prep-for-spring-game","kind":"premium","site_id":108,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-25T17:53:21.392-05:00","summary":"The format for OSU&#x0027;s spring game this Saturday has been set. ","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/cowboys-enter-final-prep-for-spring-game","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1917185,"title":"Grad transfer guard commits","slug":"grad-transfer-guard-commits","kind":"free","site_id":108,"sport":"basketball","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-04-24T13:13:10.151-05:00","summary":"Oklahoma State has picked up a commitment from Upstate NY grad transfer Mike Cunningham","deleted":false,"author_name":"Corey Evans","author_title":"Basketball Analyst","permalink":"https://basketballrecruiting.rivals.com/news/oklahoma-state-lands-grad-transfer-guard-mike-cunningham","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1916547,"title":"Game Thread: Cowboys go for another sweep","slug":"game-thread-cowboys-go-for-another-sweep","kind":"premium","site_id":108,"sport":"baseball","news_type":"team","content_type":"Content::Link","live_at":"2018-04-22T13:02:33.069-05:00","summary":"Your Big 12-leading Pokes are going for a series sweep of Kansas on Sunday.","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.forums.rivals.com/threads/sunday-baseball-pokes-go-for-another-sweep.71651/","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1914565,"title":"Boynton making things happen","slug":"boynton-making-things-happen","kind":"premium","site_id":108,"sport":"basketball","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-16T13:05:37.726-05:00","summary":"As noted in our last update, it was a big weekend for Oklahoma State hoops. And it continued in to Monday morning","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/boynton-making-things-happen","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1914298,"title":"Cowboys sign 3-star center","slug":"cowboys-sign-3-star-center","kind":"free","site_id":108,"sport":"basketball","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-15T16:45:47.831-05:00","summary":"It was a very busy, important weekend for Cowboy basketball and coach Mike Boynton","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/cowboys-sign-3-star-center","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1913173,"title":"Gunnell set for big visits...including OSU","slug":"gunnell-set-for-big-visits-including-osu","kind":"free","site_id":108,"sport":"football","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-04-11T17:10:02.746-05:00","summary":"Rivals100 QB Grant Gunnell has several big visits upcoming, including OSU.","deleted":false,"author_name":"Adam Gorney","author_title":"Rivals.com recruiting Analyst","permalink":"https://oklahomastate.rivals.com/news/qb-grant-gunnell-planning-big-visits-starting-soon","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1912605,"title":"The 2020 Hot 11 debut","slug":"the-2020-hot-11-debut","kind":"premium","site_id":108,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-10T13:57:07.330-05:00","summary":"Ever a favorite here at OSI, we&#x0027;re trying something new with the Hot 11 - namely debuting very early","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/the-2020-hot-11-debut","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1912384,"title":"Cowboys sweep K-State","slug":"cowboys-sweep-k-state","kind":"free","site_id":108,"sport":"baseball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-09T21:50:36.321-05:00","summary":"How sweep it is - the Cowboys picked up their second Big 12 series sweep in a row in Manhattan on Monday afternoon.","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/cowboys-sweep-k-state","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1911029,"title":"Gundy has clear goals for spring","slug":"gundy-has-clear-goals-for-spring","kind":"free","site_id":108,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-04T21:33:10.760-05:00","summary":"5 practices in to spring football, OSU head coach Mike Gundy has clear goals in mind for the top priorities in spring","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/gundy-has-clear-goals-for-spring","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1910306,"title":"Pokes enter week 2 of spring: \"Real football on tap\"","slug":"pokes-enter-week-2-of-spring-real-football-on-tap-","kind":"premium","site_id":108,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-03T11:32:17.843-05:00","summary":"Oklahoma State football entered their second week of spring practice on Monday. ","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/pokes-enter-week-2-of-spring-real-football-on-tap-","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1909955,"title":"Cowboys, Spartans, Red Raiders keeping uo with Taurean Carter","slug":"cowboys-spartans-red-raiders-keeping-uo-with-taurean-carter","kind":"free","site_id":108,"sport":"football","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-04-02T10:49:33.754-05:00","summary":"Oklahoma State is one of three schools in good shape with defensive lineman Taurean Carter","deleted":false,"author_name":"Josh Helmholdt","author_title":"Midwest Analyst","permalink":"https://Oklahomstate.n.rivals.com/news/cowboys-spartans-raiders-keeping-up-with-taurean-carter","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1908679,"title":"Big announcement from Cowboy baseball on Thursday","slug":"big-announcement-from-cowboy-baseball-on-thursday","kind":"free","site_id":108,"sport":"baseball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-28T14:11:30.734-05:00","summary":"It appears the long-awaited announcement of a new stadium for Cowboy baseball is imminent. ","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/big-announcement-from-cowboy-baseball-on-thursday","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1908389,"title":"Spring football is under way","slug":"spring-football-is-under-way","kind":"free","site_id":108,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-27T16:59:29.445-05:00","summary":"Oklahoma State football started their spring session bright and early on Tuesday morning, with a 6 a.m. start. ","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/spring-football-is-under-way","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1908299,"title":"Relationship between OSU and 2020 Eli Russ already strong","slug":"relationship-between-osu-and-2020-eli-russ-already-strong-1","kind":"free","site_id":108,"sport":"football","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-03-27T13:15:21.111-05:00","summary":"OSU was the first P5 offer for in-stater Eli Russ and the relationship is strong.","deleted":false,"author_name":"Josh Helmholdt","author_title":"Rivals.com recruiting Analyst","permalink":"https://oklahomastate.rivals.com/news/relationship-between-osu-and-2020-eli-russ-already-strong","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]},{"id":1907766,"title":"Hot 11: Version 2.0","slug":"hot-11-version-2-0","kind":"free","site_id":108,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-26T08:00:00.000-05:00","summary":"Our second edition of the 2019 Hot 11 features three new additions.","deleted":false,"author_name":"Jeff Johnson","author_title":"Publisher","permalink":"https://oklahomastate.rivals.com/news/hot-11-version-2-0","site_name":"OStateIllustrated.com","type":"Content","programming":[],"associated_links":[]}], nil, 108, nil, true); subdomain = &#x0027;oklahomastate&#x0027;; aolPlayerId = &#x0027;58e686759efa8936610b8215&#x0027;; aolCompanyId = &#x0027;58e68374c7480e728bcc385f&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #dd5309'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-homepage-forums ad-referer='https://oklahomastate.rivals.com/news/xavier-ross-on-his-official-visit' background-color='#dd5309' base-api-url='https://oklahomastate.forums.rivals.com/' homepage='false' message-board-url='oklahomastate.forums.rivals.com' pub-ad='null' size='size' space-id='2022733131' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://oklahomastate.rivals.com/news/xavier-ross-on-his-official-visit/printable' site-name='OStateIllustrated.com'></rv-share-links>
</div>
<div class='premium-icon'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-04-30 21:13:39 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1919146/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Xavier Ross on his official visit</h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='title-sm'>
Jeff Johnson
&bull;
</span>
<span class='type-sm'>OStateIllustrated.com</span>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Publisher</span>
</span>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='upsell'>
<div class='preview-container'>
<div class='article-preview'></div>
<div class='fade-container'>
<div class='article-fade'></div>
<div class='st__content-block st__content-block--text article-text'>
<p>Three-star defensive tackle Xavier Ross took a trip to Stillwater this weekend, along with a large number of other prospects. Unlike the rest of them, Ross was on an official visit. We caught up wi...</p>

</div>

</div>
</div>
<div class='upsell-content'>
<div class='row premium-divider'>
<div class='col-sm-8 col-xs-6'>
<hr>
</div>
<div class='premium-content col-sm-8 col-xs-12'>
<div class='premium-icon'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<span>Premium Content</span>
</div>
<div class='col-sm-8 col-xs-6'>
<hr>
</div>
</div>
<h3 class='upsell-headline'>Subscribe today to read the full article and get everything Rivals has to offer.</h3>
<div class='row buttons'>
<div class='col-xs-24 col-sm-12'>
<div class='subscribe'>
<a class="btn" href="/sign_up?preselected_site_id=108">Subscribe to Rivals</a>
</div>
</div>
<div class='sign-in col-xs-24 col-sm-12'>
<a class="btn" href="/users/sign_in">Sign in</a>
</div>
</div>
<div class='value-props row'>
<ul>
<li class='value-prop fa-before fa-check'>Member-only message boards</li>
<li class='value-prop fa-before fa-check'>Exclusive highlights and recruiting interviews</li>
<li class='value-prop fa-before fa-check'>Exclusive coverage of Rivals Camp Series</li>
<li class='value-prop fa-before fa-check'>Breaking recruiting news</li>
</ul>
</div>
</div>
<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>

</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://oklahomastate.rivals.com/news/xavier-ross-on-his-official-visit/printable' site-name='OStateIllustrated.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' site='{"id":108,"legacy_id":932,"name":"OStateIllustrated.com","friendly_name":"Oklahoma State","annual_discount":null,"subdomain":"oklahomastate","primary_color":"dd5309","secondary_color":"000000","font_color":"ffffff","short_name":"oklahomastate","maple_ncaaf_team_id":25,"maple_ncaaf_endpoint":"ncaaf/teams/ood","maple_ncaab_team_id":446,"maple_ncaab_endpoint":"ncaab/teams/oag","maple_college_id":25,"google_analytics_id":"UA-81921705-1"}' twitter-feed='{"id":108,"site_id":108,"handle":"@okstaterivals","list_name":"","created_at":"2016-02-01T12:25:17.356-06:00","updated_at":"2016-06-16T11:29:05.975-05:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://oklahomastate.rivals.com/news/xavier-ross-on-his-official-visit/printable' site-name='OStateIllustrated.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733131', 'https://oklahomastate.rivals.com/news/xavier-ross-on-his-official-visit');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Xavier Ross on his official visit";
  _sf_async_config.sections = 'content,content-football,content-football-premium,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://oklahomastate.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733131",
    c7: "https://oklahomastate.rivals.com/news/xavier-ross-on-his-official-visit"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Foklahomastate.rivals.com%2Fnews%2Fxavier-ross-on-his-official-visit&c5=2022733131&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
